I noticed a slight change in naming convention for interfaces. Which one is the current standard or recommended guidance?
In the Harmony Deskbook 4.1:
Interfaces names should be referenced to the sender port. Naming convention: i<Sender>_<Receiver>.
In Harmony MBSE Modeling Standards for use with UML, SysML, and Rhapsody:
Interfaces shall be named in terms of their semantic concept (e.g. iNavData or FLIRCommands) and their names shall be prefixed with a lower case 'i'.
In simple cases (a single interface between blocks) I use the i<Sender>_<Receiver> or, if I'm using interface blocks ib<Sender>_Receiver>. If the interface is complex enough to warrant multiple interfaces, then I switch the the latter semantic-oriented interface naming convention.
Unlike many people, I use the lower case "i" in interfaces because uppercase "I" looks like a one or lower case "L" in many fonts.